RoboRegistrar Connectivity Issues

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Jul 15, 2024 - 16:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2024 - 13:52 UTC

Investigating

RoboRegistrar is currently experiencing issues. Investigation ongoing.
Posted Jul 15, 2024 - 06:20 UTC
This incident affected: Integrations (RoboRegistrar).