Order Delivery Delays

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 19:16 UTC

Investigating

We are investigating an issue where some orders are delivering slower than expected, we will provide more info as it is available.
Posted Dec 15, 2025 - 18:20 UTC
This incident affected: Consumer (Ordering).