Company Wide Meeting
Incident Report for Parchment Inc
Resolved
Thank you for your patience. We were able to complete our meeting quickly and all support services are now operational.
Posted Jul 25, 2024 - 14:46 UTC
Investigating
The Parchment support team will be in a company wide meeting from 10:30-11:30 Eastern today July 25, 2024. During this time web case submission will be available but phone support will be paused.
Posted Jul 25, 2024 - 14:24 UTC
This incident affected: Supporting Services (Parchment Support).