Parchment Support Holiday Closures
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jan 03, 2022 - 06:11 PST
Identified
The holiday season is upon us. The Parchment team, and specifically Parchment Support, will be closed or providing limited services on the following dates:
11/25 CLOSED
11/26 CLOSED
12/10 Expect some delays in support for administrators and students on 12/9 and 12/10 as we travel to gather in person for our annual employee meeting and holiday party being held on 12/10. There will be no phone support for students / test takers on 12/10. Students can submit a web case through www.parchment.com for assistance. Parchment Print will operate as usual.
12/24 CLOSED
12/31 CLOSED
Best wishes from the Parchment Support team for a happy and healthy holiday season!
Posted Nov 22, 2021 - 07:50 PST
This incident affected: Consumer (Learner (Login, Registration & Ordering), Administrator (Login & Processing)), Parchment 6 (Administrator (Login & Processing)), Credentials Solutions (TranscriptsPlus), and Parchment 7 (Administrator (Login & Processing), Learner (Login, Registration & Ordering)).