Increased number of errors being reporting in the "In Process" queue

Incident Report for Parchment Inc

Resolved

This incident has been resolved.
Posted May 20, 2025 - 18:39 UTC

Identified

We are currently working on fixing the orders in the processing queue that are in an error status as of this morning.
Posted May 20, 2025 - 15:13 UTC
This incident affected: Parchment Award - Transcript Services.