TranscriptsPlus (www.credentials-inc.com) is Down
Incident Report for Parchment
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 17:10 PDT
Investigating
We are currently investigating this issue.
Posted Jun 22, 2022 - 06:58 PDT
This incident affected: Credentials Solutions (TranscriptsPlus).